Good things to know
Setting up a new sheet

When setting up assessment spreadsheets, try to include the maximum amount of information that you can for each child. This will be invaluable later when you come to calculate targets or see who is under performing.

As a minimum, include first and second names in separate columns, form group, gender, set, KS2 data, KS3 MTG, English KS2 or KS3 level (this has a direct bearing on science performance). Desirable: full KS2/KS3 data (En, Ma, Sci), G&T, SEN, addresses so that you can send congratulatory letters (or otherwise) out automatically.
It is best to get this data from the school system, as you will then know that it is up to date. Maintenance throughout the year as students arrive and leave is essential.

Splitting and Freezing Panes

Found on the Window Menu. Invaluable for use with large sheets as students’ names and titles can be frozen whilst the data is scrolled horizontally or vertically.

Hiding Columns and Sheets

To hide a column or columns, select them by left-clicking the column(s) letter(s) and then right click on the selection. Hide is an option in this menu. This enables you to get rid of a lot of the stuff that staff do not need to see on a day-to-day basis.

To hide a sheet, Format Menu>Sheet>Hide. I use this to hide analysis sheets meaning that the front sheet that is seen by the staff is clean and free from complications.

Inserting a Sheet

If the standard three sheets is not enough then you can add extra sheets for all your analysis by going to the Insert Menu>Worksheet. Double click on tab at bottom of screen to rename. Some Science Spreadsheets have up to 10 tabbed sheets although the staff might only use the first one.

Paste Special

When copying data to new sheets, be aware that you can use Paste Special from the Edit Menu to copy formulae or formats rather than the data. Alternatively you can Paste Special>Values to get rid of formulae and leave you with pure numbers – this is sometimes useful.
Find

In the Edit Menu, the Find function is tremendously useful for locating a piece of data. 
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Colour and Conditional Formatting

The use of colour can bring clarity to sheets. I used colour for class groups so when a re-set occurs at a Faculty Meeting it is very easy to see which sets students have come from. However a clever way to use colour is via conditional formatting: select cells to be formatted and then Format Menu>Conditional Formatting. You can then add logical conditions to the cells (up to three) so that under (and over) performing students can be identified. To add more formats, click Add in the pop up window.
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Example: With a Year 9 sheet I have green for anyone exceeding MTG. Orange is MTG to MTG-0.4 and Red is MTG-0.4 down to MTG-7.

Printing (set print area)

Spreads can get very large so select the cells to be printed and then use File>Print Area>Set Print Area to print the desired cells. Once the area is selected you can then check the print preview as only this area will be shown until you clear it (found in the same menu).

Printing Title Rows

File Menu>Page Setup>Sheet allows you to print the same rows at the top of every page. Very useful when printing off a large sheet – every page will have the correct titles so that it can be read easily.

Filters

Data Menu>Filter>Auto Filter will bring up a filter on each column so that you can get rid of data you do not want to view. 

Example: once filters are in place you could use the filter in the gender column to only show the girls’ data if you were looking at the performance of girls compared to boys.

Autoshapes

These can be activated from the Insert Menu>Picture>Autoshapes. They are a collection of simple shapes like arrows which can be used to highlight particular parts of a spreadsheet:
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Useful Formulae

Calculating grades or levels.
I would expect you know how to insert formulae with the fx button on the toolbar. However, of you have not ventured beyond SUM and AVERAGE, here are some functions I have found useful:

Nested IF

=IF(E3>=$E$197,7,IF(E3>=$E$196,6,IF(E3>=$E$195,5,IF(E3>=$E$194,4,IF(E3>=$E$193,3,IF(E3>=$E$192,2,0))))))

This is a nested IF statement which compares cell E3 to values in cells E197 to E192. If the value is greater or equal to E197 then the value 7 is attributed to the cell in which this formula is written. If the value is less then this the comparison is made with E196, E195 and so on. The final default value is 0. The values 7 to 2 could be KS3 levels. For KS4 grades could be used.

Dollar signs in the equation mean that the same cells (E197 to E192) will be referred to when you copy the equation down the spread. As you probably know, Excel automatically increases the numbers of cells in copied equations so the second cell down would refer to E198 to E191 if you pasted without the $ signs.

Vlookup

The above ‘Nested IF’ formula can be useful but another way to achieve this effect but with more precision is with a lookup table:

[image: image4.png]Mark | |Mark Level

s s 4
41

6 42

0, 7 43
44

s 45

s 5

1 47
0, 45

11 )

12 12 s
]

13 13 52
14 53
14 54

18 55
18 5

18 57
17 18 58
58

18 17 6
61

18 62




The following formula looks in the first column of this table to find the corresponding level in the far right hand column, based on the value in cell W3.

=IF(W3>0,VLOOKUP(W3,$W$198:$Z$223,4),0)

The ‘IF W3>0’ is to prevent lots of DIV#0 errors appearing, i.e. the formula only calculates if W3>0 else ‘0’ is returned – useful when calculating averages from this cell!

If you wanted to lookup using the third column of the above data (could be marks in a second test) to find the corresponding level then the formula becomes:

=IF(W3>0,VLOOKUP(W3,$Y$198:$Z$223,2),0)

The ‘2’ at the end tells Excel to look for a corresponding level in column 2 whereas the first equation said ‘4’.

The above example assumes that the lookup table is located in cells W198 to Z223.

Rounddown

=ROUNDDOWN(AH3,0)

Rounds a number down to the next integer value. 

Example: you have a child on level 5.6. Rounddown produces 5 from this number. 5 can be subtracted from 5.6 to give 0.6 in the next cell. A nested if statement can then be used to calculate a sub level.

=IF(AS3<=0.34,"c",IF(AS3<=0.7,"b","a"))

As can be seen this will give a ‘c’ if the discrepancy is below 0.34, etc. For my example the sub level will be a ‘b’. You can then concatenate as follows to give a final level for staff:

=Q2&Q3

If Q2 was 5 and Q3 was b the above formula produces 5b in its cell. You can then hide the columns that you used to create this effect.

Analysing Results

Countif

I advise against using A* in KS4 sheets – use @ as it is easier to deal with in formulae. COUNTIF cannot normally distinguish between A and A*.
COUNTIF can be used to count the number of times a particular grade appears in a column.

=COUNTIF($AI$3:$AI$175,"E")

This counts all the grades in column AI3 to AI175 that are ‘E’ grades. You can then use this number to produce a percentage of the year with an E grade, etc. If you use lookup tables as suggested above then you can adjust the values in the table until the percentage of children at each grade matches your requirements (e.g. setting grade boundaries for mock exam results becomes an easy task).

Text Functions

I hope the above has served as a reasonable taster for the sorts of formulae you can use. I would urge you to click on fx and peruse. Some of the text functions, for instance, are beautifully elegant and can get you out of a hole, e.g. the school data has come with children’s first and second names in one column. No problem: 

=FIND(",",A149)

in cell B149 finds the comma between names in cell A149.

=LEFT(A149,B149)

can then be used to only take the left hand characters of A149 up to the comma (given by B149). Obviously, take 1 off the B149 value of you do not want the comma to appear so the formula becomes:

=LEFT(A149,B149-1)

Note: As with most things in Excel you can accomplish the above ‘name-splitting’ in more ways than one – I have described using ‘Text-to-Columns’ in another part of these training documents.

Macros

Excel and other Microsoft applications are modifiable!

Once you tire of formulae you will want to try writing some functions that make Excel work even better for you!

You can even record a macro yourself without the need to programme. Simply go to Tools Menu>Macros>Record New Macro. Start recording and stop when you have performed a sequence of tasks. Copying and pasting a few cells is a good start. To play the macro, use the play button on the same menu. You can also assign a macro to an image that you insert on the sheet; right-click on the image and then assign a macro. This means that the user can then click on the image to use the macro. I tend to use WordArt images, e.g. ‘Print Class’, so it is obvious to users.

You can see the result of your handiwork above by opening the Visual Basic Editor from the Macros menu. Excel has turned your sequence of events into code (Visual Basic) which is fairly easy to pick up with a bit of logic. Later in this section you will see some code which I wrote in the editor to perform a certain function but I learnt about Visual Basic by recording my own macros and seeing what the code looked like.

So what use are macros?

Here is a classic problem that occurred to me:

My KS3 and KS4 sheets had got rather large and staff were having lots of problems trying to print out the bits they wanted with the correct titles, columns, etc (there were at least 50 columns and 200 students per year group). Henceforth, I wrote a macro to accomplish this task for them.

In the macro’s code below, Clas is a global variable, which means it can be used throughout the program.

[image: image5.png]Public clas s String

Sub Set_ireal)
' Set_iTea Macro

' Macto recorded 25/09/2004 by Peter Hart
Dim x As Integer

Dim first is Integer

Dim last s Integer

UserFornl.Show

first = 1
last = 1

Application.Screenlpdating = False

activeSheet. Unprotect

For x = 3 To 180
Cellsix, 5).Select

If Selection = clas And Cells(x - 1, 5] <> clas Then first = Selection.Row
If Cells(x + 1, 5] <> clas And Selection = clas Then last = Selection.Row
Next

Colunns (": RO") .Select
Selection.EntireColumn.Hidden = True

Colunns ("6:N") .Select

Selection.EntireColumn.Hidden = True

AetiveSheet.PageSetup.Printhrea = Range (Cells(first, 1), Cells(last, 30)).Address
ctiveWindow. SelectedSheets.PrintOut Copies:=1, Collate:=True
Colunns (W: 0" .Select

Selection.EntireColum.Hidden = False

Application.Screenlpdating = True

ActiveSheet.Protect DrawingObjects:=True, Contents:=True, Scenarics
End sub





The Userform referred to in the code pops up when the macro is run so that the user can select their class, which becomes variable ‘clas’. The Userform appears like this to the user:
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The Userform code is as follows:

[image: image7.png]Public Sub ComwandButtonl Click(
If OptionButtonl.Value Then
clas = "R"

Elself OptionButton2.Value Then
clas = "o

Elself OptionButton3.Value Then
clas = "yn

Elself OptionBuctond.Value Then
clas = "G

Elself OptionBuctonS.Value Then
clas = "B"

Elself OptionBuctons.Value Then
clas = "In

Else: clas = ""

End If

UserFornl.Hide

End sub





You now need to refer back to the first bit of code and see that after the Userform input, the program now knows the value of the variable ‘clas’. The For-Next loop then searches for the students in the selected set. This code relies on the students already being sorted into groups – I have written a macro that gets round this but that is for another day…

The next bit of the code hides columns that are not needed. The selection of the print area is then set in the next lines and then the sheet is printed. 

If the lines about screenupdating are not included then the screen updates whilst the macro runs and so flickers disconcertingly.

The possibilities are limitless. I recently produced a macro that produces an exam result scatter sheet from an Excel sheet via one click of the mouse. It saves a good hour’s work for a year group, as you do not have to write or type children’s names onto the grid next to their mark.

Some useful links

VBA For Dummies is a superb book if you want to get into Visual Basic programming.

http://www.mrexcel.com/ - good message board help for ideas.

http://www.j-walk.com/ss/help/ - good for searching for solutions to problems.

http://office.microsoft.com/en-gb/assistance/CH010485201033.aspx - Microsoft’s help pages.

Putting Excel + your problem into Google will normally reveal a solution somewhere on the web!

GOOD LUCK!

